UK: Delay with tax submissions

Incident Report for Xero

Resolved

HMRC has resolved the issue impacting tax submissions by UK customers for Personal Tax, Partnerships Tax, Corporate Tax an VAT and submissions are processing as normal.
Posted Aug 05, 2025 - 09:24 UTC

Investigating

We are aware that tax submissions by UK customers for Personal Tax, Partnerships Tax, Corporate Tax, CIS and VAT may be experiencing delays due to an issue with HMRC. Our team are in contact with HMRC and investigating this with urgency.

Status Last Reviewed: 16:10 UTC.
Posted Aug 04, 2025 - 15:31 UTC
This incident affected: United Kingdom - Regional Products (Tax Reporting - UK VAT & MTD) and Xero Partner Products & Tools (Xero Tax (UK)).